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Safety Information

Electrical safety
® To prevent electrical shock hazard, disconnect the power cable from the electrical outlet before

relocating the system.

When adding or removing devices to or from the system, ensure that the power cables for the
devices are unplugged before the signal cables are connected. If possible, disconnect all power
cables from the existing system before you add a device.

Before connecting or removing signal cables from the motherboard, ensure that all power cables

are unplugged.

Seek professional assistance before using an adapter or extension cord. These devices could

interrupt the grounding circuit.

Make sure that your power supply is set to the correct voltage in your area.

If you are not sure about the voltage of the electrical outlet you are using, contact your local

power company.

If the power supply is broken, do not try to fix it by yourself. Contact a qualified service

technician or your local distributor.

Operation safety

® Before installing the motherboard and adding devices on it, carefully read all the manuals that
came with the package.

® Before using the product, make sure all cables are correctly connected and the power cables are
not damaged. If you detect any damage, contact your dealer immediately.

® To avoid short circuits, keep paper clips, screws, and staples away from connectors, slots,
sockets and circuitry.

® Avoid dust, humidity, and temperature extremes. Do not place the product in any area where it
may become wet.

® Place the product on a stable surface.

® |f you encounter any technical problems with the product, contact your local distributor

Statement

® All rights reserved. No part of this publication may be reproduced in any form or by any means,
without prior written permission from the publisher.

® All trademarks are the properties of the respective owners.

® All product specifications are subject to change without prior notice
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Chapter 1: Product Introduction

1.1 FRONT VIEW

F13~F20 Function Keys

F1~F6
Function Keys

F7~F12
Function Keys

Non-functio Power Button
Dim + Power LED indicator

Dim -

1.2 REAR VIEW

Water proof 1x DC-IN 1x USB2.0 GND screw

valve oy~zey XHOMI
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1.3 ME DIMENSION
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Chapter 2: Components

2.1 LOCATION
Acleanandmoisture free environment is preferred. Make room for air circulation. Avoid areas with:
® Sudden or extreme changes in temperature.
® Extreme heat.
® Strong electromagnetic fields.
® Dust or high humidity.
If it is necessary to work in a hostile environment, please regularly maintain your display by
cleaning dust, water, etc. to keep it in optimal condition.

2.2 RUGGEDNESS

The display is designed with rugged features such as vibration, shock, dust and rain/water
protection. However, it is still necessary to provide appropriate protection while operating in harsh
environments. NEVER immerse the unit in water. Doing so may cause permanent damage. All
connectors will corrode if exposed to water or moisture. Corrosion is accelerated if the system’s
power is ON. Please take proper water-resistant measures for cable connections.

The DC jack and cables are sealed and may be operated with water splashing while attached. All
port covers should be in place when no cable is attached.

2.3 POWER SUPPLY
The display can be powered via DC-IN (18~36V). Optional: MIL-STD-461, MIL-STD-1275

2.4 DISPLAY PANEL
The panel of the CLOUD15 series is a 4:3,1024 x 768 XGA panel with typical 1000 cd/m2 brightness,
a contrast of 2000:1 and a LED backlight.

2.4.1 BRIGHTNESS
The brightness of the display can be changed by simple pressing the brightness up/down keys in
normal operational mode.

2.5 G.F.G SCREEN

CLOUD15 series is equipped with a 15” G.F.G screen. The screen can be connected and used with an
external LCD panel via the HDMI ( by cable kit) interface. It is designed to meet requirement and
environmental specifications dictated by the nature of military systems.

15 " TFT LCD Display screen

Resolution 1024x768 XGA Brightness 1000 Nits
Aspect Ratio 4:3 Contrast Ratio 4000
Touch Panel Glass-Film-Glass panel
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Chanter 3: Specification

3.1 15” TFT LCD DISPLAY
Resolution 1024x768

Aspect Ratio 4:3

Touch Panel

SYSTEM SPEDC
Function key

9V ~ 36V DC-IN, 28Vdc
DC-IN

Brightness

Contrast Ratio

Up to 1000 Nits
4000:1

Glass-Film-Glass panel (Options: 5-Wire resistor touch)

Programmable Function Keys (F1~F20)

Optional:12V~40V DC-IN (150W max) MIL-STD-461, MIL-STD-1275,

CONNECTORS
Rear 1/O Port 1x  Water Proof valve
[X1]
[X2]

[X3]

1x GND screw
APPLICATIONS
Applications

PHYSICAL

1x DC-IN MIL-38999
1x  HDMI with MIL-38999
1x  USB2.0 with MIL-38999

Anodic aluminum oxide

Dimension 442.5x72x370mm (17.42" x 2.84" x 14.57")
Weight 12.0kg(26.43Ibs) Finish
Chassis

Aluminum Alloy,
Corrosion Resistant.

MIL COMPLIANCE

MIL-STD-810 (OPERATION TEST)

Low Temp. Method 502.5 Procedure 2
High Temp. Method 501.5 Procedure 2
Humidity Method 507.5 Procedure 2
Vibration Method 514.6 Category 20
Shock Method 516.6 Procedure 1
MIL-STD-810 (NON-OPERATING TESTS)
Low Temp. Method 502.5

High Temp. Method 501.5 Procedure 1
Vibration Method 514.6 Category 24

Ingress Protection

IP65 Dust /water Proof

Exposure(24h x 3 cycle) at -10°C min.

602C for 2 hrs after temperature stabilization.

RH -95%. Test cycles: ten 24-hrs , functional test
after 5th and 10th cycles

10 - 500Hz 1.04Grms Test duration: 1 hr x 3 axis
(total 3 hrs)

10G, 11mSec, 3 per axis

Exposure(24h x 7 cycle) at-20°C min.

71°C for 2 hrs after temperature stabilization.
200 to 2000Hz Test duration: Thr per axis; rms =
2.24 gs
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Shock Method 516.6 Procedure 1 20G, 11mSec, 3 per axis

MIL-STD-461

CE102
RE102-4 (1.5 MHz) -30 MHz - 5 GHz
RS103 1.5MHz -5GHz, 50V/m equal for all frequencies

EN 61000-4-2: Air discharge: 8 kV,
ENVIRONMENTAL QUALIFICATIONS

Regulatory CE, FCC, Compliance
Operation Temp. -20~+60 °C

Storage Temp. -40~+85 °C

Green Product RoHS, WEEE compliance

10
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3.2 1/0 INTERFACE
3.2.1 (X1) 1x DC-IN

D38999/20FRZPN 038999/ 20FB2PN

FRONT BACK

BACK

D38999/20FB2PN
DC-IN
A Vint
B Vin-
3.2.2 (X2) 1x HDMI 2.0
Pin # Signal Pin # Signal
1 HDMI_TX2_P GND
3 HDMI_TX2_N HDMI_TX1_P
5 GND HDMI_TX1_N
7 HDMI_TX0_P GND
9 HDMI_TXO0_N HDMI_CLK_P
1 GND HDMI_CLK_N
13 CEC NC
15 HDMI_SCL HDMI_SDA
17 GND +5 V Power
19 Hot Plug Detect GND
21 GND GND
23 GND
3.2.3 (X3) 1x USB2.0 CONNECTOR
' D38999/20FA355N
D38999/20FA35SN 38999/ 20F A35SN USB2. 0

| U | = (o [ [ —
=
t
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Chapter 4: Operation Introduction

F13~F20 Function Keys

F1~F6
Function Keys

F7~F12
Function Keys

Dim -

4.1 F1~F20 FuNCTION KEYS

Programming function keys could be customized depend on customer’s requirement.

4.2 POWER BuUuTTON

Turn the LCD Panel powe on by pressing the power button. Turn the display Off by
pressing the power button again.

4.3 LED INDICATORS

Green: When Power is “ON”.

4.4 BRIGHTNESS UP OR DOWN

Dim+:LCD backlight increase

Dim-:LCD backlight decrease

4.5 FN-KEY BACKLIGHT ON OFF

Non function Key.

12
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Chapter 5: Programable Function Key Setup - PreFace Under Window

(03

o D
A

ﬂ o= S Function Key for Panel PCv = = = = = = = = -
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All operations within this document must be performed with the HotKey hardware connected in

order to function properly.

5.1 START HOT KEY INTERNATIONAL VERSION

Click the Hot Key International Version.exe program and wait for it to finish initializing.

Once the program interface appears, it means that the initialization is complete and you

can proceed with the operations. If the hardware is not connected or cannot be connected

properly, an error message "Hardware Connect Fail" will appear.
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Click the Hot Key International Version.exe program and wait for it to finish initializing.
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Once the program interface appears, it means that the initialization is complete and you
can proceed with the operations.

>
Hardware Connect Fail

If the hardware is not connected or cannot be connected properly, an error message
"Hardware Connect Fail" will appear.

5.2INTRODUCTION TO HOTKEY TRIGGER MODE OPERATION

This chapter demonstrates the steps for setting up Trigger mode, including Save
Cmd/Delete Step/Cancel Edit.
5.2.1 HOTKEY TRIGGER MODE - SAVE CMD

Clicking on the first command "F1" will bring up a window to select Trigger Mode and Key

Combination Mode. Select Trigger Mode and then choose "W" after entering Trigger Mode.

Press "Save Cmd" to write the command to the hardware.

14
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Clicking on the first command "F1" will bring up a window to select Trigger Mode and Key
Combination Mode. Select Trigger Mode
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Select Trigger Mode and then choose "W" after entering Trigger Mode. Press "Save Cmd" to
write the command to the hardware.

5.2.2 HOTKEY TRIGGER MODE -

Select the instruction to be deleted in the instruction display window, and then press
"Delete Step". Confirm that the instruction in the instruction display window has been

deleted to complete the deletion action.

DELETE STEP

n
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m
N

EHERERE R R EEEE

w| alw|e r | T|Y

Caps |
Lock A S | D F G H

shit | Z X C A B N

Save
(md

[ECN Cancel
Step (LI

F6 | F7 | F8 | F9

F10 | F11

+

)
]

Alt

F12

Backsp
ace

|
\

Enter
‘ Shift

l

Print | Scroll
Screen | Lock

Insert | Home

Delete | End

Top

Left | Down
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Break

Page
up

Page
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Right

m
Y
w

m
=
-3

F15

Select the instruction to be deleted in the instruction display window, and then press

"Delete Step"
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Confirm that the instruction in the instruction display window has been deleted to
complete the deletion action.

5.2.3 HOTKEY TRIGGER MODE — CANCEL EDIT

Click "Cancel Edit" and wait to return to the splash screen to complete the operation.
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Click "Cancel Edit" and wait to return to the splash screen
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Returning to the splash screen signifies the completion of the operation.

5.3 KEY COMBINATION MODE INTRODUCTION

This chapter demonstrates the operation steps for setting up the Key Combination Mode,
including Save Cmd/Delete Step/Cancel Edit.

5.3.1 HOTKEY KEY COMBINATION MOD - SAVE CMD

Clicking on the first command "F2" will bring up a window to choose between Trigger
Mode and Key Combination Mode. Selecting Key Combination Mode will take you to a
window where you can choose "Ctrl" on the left, which will bring up a window with three
options: Open, Press, and Cancel. Select "Press" here, where Open indicates releasing the
key, Press indicates pressing the key, and Cancel indicates cancelling the action. Once the
configuration is complete, the instruction display window will show the configured
command. Since the Key Combination Mode is designed to provide combination function,
the action to be performed here is to simulate the "Select All" action. Therefore, you need
to sequentially configure the "Ctrl" and "A" on the left to be in the "Press" state, followed by
configuring the "Ctrl" and "A" on the left to be in the "Open" state, and then click on "Save
Cmd" to write the command into the hardware.

18
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Clicking on the first command "F2" will bring up a window to choose between Trigger
Mode and Key Combination Mode.
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Choose "Shift" on the left, which will bring up a window with three options: Open, Press,
and Cancel. Select "Press".
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Once the configuration is complete, the instruction display window will show the

configured command.
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Sequentially configure the "Shift" and "A" on the left to be in the "Press" state, followed by

configuring the "Shift" and "A" on the left to be in the "Open" state, and then click on "Save

Cmd" to write the command into the hardware.
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5.3.2 HOTKEY KEY COMBINATION MOD - DELETE STEP

In the instruction display window, select the command to be deleted, and then click on
"Delete Step". Confirm that the command has been deleted in the instruction display
window to complete the deletion action.
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In the instruction display window, select the command to be deleted, and then click on
"Delete Step".

Confirm that the command has been deleted in the instruction display window to
complete the deletion action.

5.3.3 HOTKEY TRIGGER MODE — CANCEL EDIT

Click on "Cancel Edit" and wait until you return to the splash screen to complete the

operation.
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Click on "Cancel Edit" and wait until you return to the splash screen.
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Returning to the splash screen signifies the completion of the operation.
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Click "Exit" and wait to return to the Windowscreen
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Note 1: This control program is only applicable to display settings with resolutions between 1024 x
768 and 1920 x 1080.

Note 2: This control program is only applicable under OS of Windows 10 and is not guaranteed to
be used on other platforms..
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Chapter 6: Programable Function Key Setup - PreFace Under Linux
(0 1)

6.1 SOFTWARE INSTALLATION

The overall installation could refer to following link
https://www.pjrc.com/teensy/td download.html

6.1.1 INSTALL ARDUINO IDE 1.8.19 (ARM 64 BIT)

Download path https://www.arduino.cc/en/software

Go to “Arduino IDE 1.8.19" download Linux ARM 64 bit version (filename shall be
arduino-1.8.19-linuxaarch64.tar.xz)

tar xvf arduino-1.8.19-linuxaarch64.tar.xz

cd arduino-1.8.19

sudo ./install.sh

6.1.2 DOWNLOAD LINUX UDEV RULES

Download path https://www.pjrc.com/teensy/00-teensy.rules
Right click on the download path, select “Save Link As..."
sudo cp 00-teensy.rules /etc/udev/rules.d/

6.1.3 INSTALL TEENSYDUINDO 1.59 ADD-ON INTO

ARDUINDO-1.8.19 FOLDER
Download path https://www.pjrc.com/teensy/td 159/Teensyduinolnstall.linuxaarch64
chmod 755 Teensyduinolnstall.linuxaarch64
./Teensyduinolnstall.linuxaarch64
By clicking “Next” to finish installation. The installation folder shall be under
“arduino-1.8.19"folder where you just extracted the Arduino IDE file earlier

6.1.4 INSTALL TEENSY LDADER APPLICATION

Download path https://www.pjrc.com/teensy/loader linux.html
select“Download Teensy Program (Jetson, R-Pi 64 bit)”

tar -xvf teensy_linuxarm64.tar.gz

Jteensy &  // Let the Teensy Loader run in the background

Teensy

blink_Fast_Teensy32.h..
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6.2S5SET UP CONNECTION PARAMETERS

oo
open arduino IDE application

The Tools -> Board -> Teensyduino menu, select “Teensy 4.1”
The Tools -> USB Type menu, select "Serial + Keyboard + Mouse + Joystick”

6.3 ADJUST FUNCTIONAL KEY VALUE

You can open the example file by using menu File -> Open.., and select

example "NV300_Teensy_4.1_Buttons.ino”

There are already 20 predefined function keys F1 to F20 in the file > you can program these
keys as your need

Use Keyboard.press(key) and Keyboard.release(key) to send individual key press and
release events. The "key" is a key code represents the character on the keyboard. Please
refer to following link for the definition of Key Code

https://www.pjrc.com/teensy/td keyboard.html

® Keyboard.press(KEY_A); represents key "A” has been press down

® Keyboard.release(KEY_A); represents key "A" has been release off

® Keyboard.printIn("F1 press") will print string “F1 press” for debugging usage. Normally
you shall not use it

® words after“//" can be represented as inline comments

6.4 SAVE, CHECK AND UPLOAD
® click File -> Save menu to save the configuration

® click . will verify if there is any wrong configuration

® click . will upload your latest configuration to the CLOUD15-P20-F2A2. During
uploading, you should see a progress bar on the Teensy Loader window

Now you can test new settings as you definded earlier
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